分类目录归档:cisco

思科三层交换机的路由功能

1.拓扑图如下,开启思科三层交换能的路由功能,让vlan 10和vlan 20能够互相访问

2.配置三层交换机

第一步:开启路由功能

switch>enable

switch#cnfigure terminal

switch(config)#ip routing

第二步:建立vlan 10,并且分配接口和ip

switch(config)#vlan 10      #创建vlan 10

switch(config-vlan)#exit              #退出

switch(config)#interface range
fastethernet0/1-2   #进入到f0/1-2接口

switch(conifg-if)#switchport mode
access   #将接口转换为access模式,默认情况下所有端口都是access模式,可以不用执行

switch(config-if)#switchport access vlan 10         #将端口组加入到vlan 10中

switch(config)#exit

switch(conifg)#interface vlan 10     #进入到vlan 10

switch(config-if)#ip address 192.168.1.1
255.255.255.0     #配置vlan的ip

switch(config-if)#no shutdown     #启用

switch(config-if)#end

switch#write

第三步:建立vlan 20,并分配接口和ip

switch(config)#vlan 20      #创建vlan 20

switch(config-vlan)#exit              #退出

switch(config)#interface range
fastethernet0/3-4   #进入到f0/1-2接口

switch(conifg-if)#switchport mode
access   #将接口转换为access模式,默认情况下所有端口都是access模式,可以不用执行

switch(config-if)#switchport access vlan 20         #将端口组加入到vlan 20中

switch(config)#exit

switch(conifg)#interface vlan 20     #进入到vlan 20

switch(config-if)#ip address 192.168.2.1
255.255.255.0     #配置vlan的ip

switch(config-if)#no shutdown     #启用

switch(config-if)#end

switch#write

3.根据拓扑图设置好ip后,发现vlan 10和vlan 20下的主机是可以互通的,而没有配置的其他主机(默认的vlan1的主机)是不能访问vlan10和vlan20的,即使vlan10和vlan1在同一个网段内都不能互相访问

远程思科交换机(switch)

1.我们都知道,可以用console线把电脑和交换机链接起来进行访问,但是在实际工作中绝大部分不是这样的,比如一个公司的分公司遍布各地,怎么办?弄一根很长的console线?还是跑到各地机房中进行处理。这都是不可取的,因此我们就要配置远程管理。

2.交换机也像手机、电脑那样有自己的操作系统,通常起名为IOS,是一个为网际互联优化的操作系统,ios为长时间有效地维护一个互联网提供了统一的规则。简而言之,它是一个与硬件分离的软件体系结构。它是一个高度智能的管理员、负责任、控制复杂的分布式网络资源。

3.为了远程我们首先给它配个ip才行,在交换机中ip地址的接口是一个虚拟的接口,称为vlan,默认的接口都是在默认的vlan 1中。

switch>enable

switch#configure
terminal   #
配置ip要在全局模式下进行

switch(config)#interface
vlan 1   #
进入到vlan 1

switch(config-if)#ip
address *.*.*.* ###.###.###.###  #
前面的*ip#号是子网掩码,注意设置的ip要和交换机本地的ip相同。

switch(config-if)#no
shutdown   #
启用

       这时我们可以ping一下如果能通说明交换机正常链接工作

       

4.配置账号密码和设置登陆连接数

switch(config)#line
vty 0 x  #
这里的x可选0-15的链接数,注意0x之间有连接数如

switch(config)#line
vty 0-5  #
6个链接数

switch(config)#login     #表示登陆到此链路来设置密码,回车

switch(conffig)#password 密码   #设置登陆密码

现在可以用telnet命令远程管理交换了

理解和配置trunk

1.在路由/交换领域,VLAN的中继端口叫做trunk。trunk技术用在交换机之间互连,使不同VLAN通过共享链路与其它交换机中的相同VLAN通信。交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层(DataLinkLayer)的技术。两台交换机上分别创建了多个VLAN(VLAN是基于Layer 2的),在两台交换机上相同的VLAN(比如VLAN10)要通信,需要将交换机A上属于VLAN10的一个端口与交换机B上属于VLAN10的一个端口互连;如果这两台交换机其它相同VLAN间需要通信,那么交换机之间需要更多的互连线,端口利用率就太低了。 交换机通过trunk功能,事情就简单了,只需要两台交换机之间有一条互连线,将互连线的两个端口设置为trunk模式,这样就可以使交换机上不同VLAN共享这条线路。

2.trunk不能实现不同VLAN间通信,需要通过三层设备(路由/三层交换机)来实现。

3.示例图

4.把两个switch的interface
fastethernet0/15都设置为trunk

switch>enalbe

switch#configure
terminal

switch(config)#interface
fastethernet0/15  

switch(config-if)#switchport
mode trunk   #设置接口为trunk模式

设置之后可以发现同一vlan直接可以互通了!

5当到达第四步骤时会发现switch1中的vlan10和vlan20可以访问switch2中对应的vlan10、vlan20。如果只想把switch1下的vlan20能够访问switch2下的vlan20 (switch1下的vlan10不能够访问switch2下的vlan10),那么我们可以拒绝vlan10的访问,只允许vlan 20的访问:

switch>enable

switch#configure
terminal

switch(config)#interface
fastethernet0/15

switch(config-if)#switchport
trunk allowed vlan 20    #允许vlan20通过trunk

switch(config-if)#switchport
trunk allowed vlan all     #允许所有的vlan通过

switch(config-if)#switchport
mode trunk            #把接口设置为trunk模式

思科交换机的vlan配置

.switch>    #第一次打开交换机显示的是用户模式

.switch>enable   #键入enable进入到特权模式

那么在特权模式下可以做些什么呢?

show命令

switch#show version      #查看系统中的版本信息

switch#show vlan   #查看vlan信息

switch#show interface    #查看所有的接口信息

switch#show interface fastethernet 0/1  #查看交换机1接口具体配置和信息

switch#show interface vlan 10      #查看交换机有个ip协议的配置信息

switch#show mac-address-table     #查看mac地址表

switch#show cdp    #查看设备的cdp全局配置信息

switch#show cdp interface fastethernet 0/15 #查看15接口的cdp配置信息

switch#show cdp traffic    #查看有个cdp包的统计信息

switch#exit            #退出特权模式

.switch#configure
terminal #
进入到全局配置模式

switch(config)#

全局配置模式下可以操作:

1.在全局模式下修改交换机名和设置密码:

switch(config)#hostname switch-2960

switch-2960(config)#enable password 密码       #设置密码

设置密码后从用户模式登陆到特权模式被要求输入密码

2.在全局模式下配置vlan

(1)基础配置

switch(config)#vlan 10   #创建vlan 10

switch(config-vlan)#exit

switch(config)#vlan 20   #创建vlan 20

switch(config-vlan)#exit

switch(config)#interface
fastethernet0/1    #
进入到接口1

switch(config-if)#switchport access vlan
10   #
把接口1加入到vlan 10

switch(config-if)#interface fastethernet0/12  #进入到接口12

switch(config-if)#switchport access vlan 10         #把接口12加入到vlan 10

switch(config-if)#interface
fastethernet0/13   #
进入到接口13

switch(config-if)#switchport access vlan 20  #把接口13加入到vlan 20

switch(config-if)#interface
fastethernet0/24  #
进入到接口24

switch(config-if)#switchport access vlan
20  #
把接口24添加到vlan 20

(2)把多个接口加入到vlan:

switch(config)#interface range f0/2-11

switch(config-if-range)#switchport access
vlan 10 


此时vlan10vlan20之间的主机是不能访问的,只有valn10或者是vlan20下的主机能够互相访问,划分vlan在公司是经常用到的,例如把财务部与其他部门分开,这样就可以达到一个限制的作用,如果你作为一个公司的管理着,有权管理和进入到所有的计算机,那么怎样实现vlan 20能够访问vlan 10的反之vlan 10不能访问vlan 20:

(3)no命令把某个接口从vlan中剔除

switch(config)#interface
fastethernet0/13   #
进入到接口13

switch(config-if)#no switchport access vlan
20   
vlan 20中剔除

switch(config-if)#interface range
fastethernet0/3-10  #
进入到接口组

switch(config-if-range)#no switchport
access vlan 10  #
把某组接口总vlan中剔除

注意被踢出vlan的主机接口口不能访问原来所在vlan

(4)关闭/删除vlan

switch(config)#interface vlan 10

switch(config-if)#shutdown      #关闭vlan 10 ;同理no shutdown 启动vlan

怎样才能把vlan删除干净:

switch(config)#interface range
fastethernet0/1-12

switch(config-if)#no switchport access vlan
10

switch(config-if)#exit

switch(config)#no interface vlan 10

switch(config)#no vlan 10

 

(5)可以进入到vlan配置ip

switch#configure terminal         #进入到配置模式

switch(config)#interface vlan 10    #进入到vlan ,是不是和进入到接口一样interface
fastethernet0/5

switch(config-if)#ip address 192.168.1.55
255.255.255.0   #
设置交换机ip

switch(config-if)#exit

switch(config)#interface vlan 20     #进入到vlan 20

switch(config-if)#ip address 192.168.3.5
255.2223.261.0

(6)光纤接口又叫光口,企业交换机一般都有几个这样的光口用于接入光纤,那么可以把vlan划分给某个光口:

switch(config)#interface
GigabitEthernet1/1    #
进入到光口1,有时候是0/1

switch(config-if)#switchport mode
access      #
设置静态vlan访问模式

switch(config-if)#switchport access vlan
10    #
vlan 10加入到光口1

switch(config-if)#exit

switch(config)#interface GigabitEthernet
1/2    #
进入到光口2

switch(config-if)#switchport mod
access   

switch(config-if)#switchport access vlan
20 

3.其他

(1)查询

switch#show interface fastethernet0/1
status  #
查看f0/1网口状态

switch#show interface fastethernet0/1    #查看f0/1网口详细配置

(2)配置默认网关

switch#configure terminal

switch(config)#ip defautl-gateway a.b.c.d

switch(config)#exit

(3)保存当前配置

switch#copy running-config
startup-config  


(4)恢复出厂设置

switch>enable

switch#write erase

switch#reload