wdcp如何升级php版本

(1)下载解压

wget -c
http://dl.wdlinux.cn:5180/soft/php-5.3.10.tar.gz

tar zxvf php-5.3.10.tar.gz

cd php-5.3.10

(2)编译安装

./configure
–prefix=/www/wdlinux/php-5.3.10 –with-config-file-path=/www/wdlinux/etc –with-mysql=/www/wdlinux/mysql
–with-iconv=/usr –with-freetype-dir –with-jpeg-dir –with-png-dir
–with-zlib –with-libxml-dir=/usr –enable-xml –disable-rpath
–enable-inline-optimization –with-curl –enable-mbregex –enable-mbstring
–with-mcrypt=/usr –with-gd –enable-gd-native-ttf –with-openssl –with-mhash
–enable-ftp –with-apxs2=/www/wdlinux/apache/bin/apxs

make

make install

(3)

mv /www/wdlinux/php /www/wdlinux/php.bak 备份之前的php文件夹连接文件

ln -s /www/wdlinux/php-5.3.10
/www/wdlinux/php 
软连接ph5.3文件夹到php

service httpd restart

 

注意

(1).make时如果出现make: ***
[ext/iconv/iconv.lo] Error 1
错误说明iconv库没有安装需要单独装一下iconv,操作如下

wget http://down.wdlinux.cn/in/iconv_ins.sh

chmod +x iconv_ins.sh

sh iconv_ins.sh

(2).php版本仅用5.3.10为例,实际上就是下载个新的php版本替代之前的,如果换其他版本的php找到下载地址并粘贴到wget后的路径即可

(3)/www/wdlinux/php文件夹其实是软链接文件,可以直接删除.


发表评论

电子邮件地址不会被公开。